Translate this page:

Welcome to our forums. Please sign-in or register

sony ericsson K850i: Won't turn on

Posted: 18:05 25 Jun 08 #1
  • tommyg89
  • 1 Post
  • Join Date: 25 June 2008

The phone turned off by itself one day and I haven't been able to turn it back on, all i get is the keys lighting up and the camera lighting up but nothing on the screen. Ive tried using the SEUS but it says everything is up to date but i continued anyway and then it said there was a failure. I'm just wondering what I should do? or how much it would cost to get it fixed?

 cheers

Posted: 18:42 25 Jun 08 #2
  • PiRo
  • 5 Posts
  • Join Date: 25 June 2008

Mine did this today, I'm just going to run it through DaVinci and try and flash it that way with latest firmware and we'll see what happens!

 Trying to do it on Vista 64bit too .. So double bad expectations.. Ill report back.

Posted: 19:38 25 Jun 08 #3
  • PiRo
  • 5 Posts
  • Join Date: 25 June 2008

Well i've done it now and had EXACTLY the same problem as you, just keypad and lens lighting up

 My fix method worked PERFECTLY.

 I installed 64bit USB Flash drivers - Because I run Vista64

Downloaded DaVinci software, Brought 10 credits (£8 approx), Flashed phone & now it works fine :)

 Cost me less than it would have to send it back recorded delievery to Sony to fix.

 PiRo

 

Edit:
I had originally tried to flash it with SEUS but this failed as it seemed to be unable to write the downloaded file. DaVinci had no such problem.

Posted: 00:53 13 Jul 08 #4
  • thebimbo1
  • 1 Post
  • thebimbo1
  • Join Date: 13 July 2008
  • Occupation: Armed Forces
  • Location: Edinburgh

hey im havin the exact same problem as you,key lights on and amera too but nothin else!this is my second sony ericsson k850i to do this. have you managed to fix yours?if so id be really grateful if you could tell me how to fix mine,im lost without my mob.

thanks x

Posted: 07:11 13 Jul 08 #5
  • anitalg
  • 10490 Posts
  • anitalg
  • Join Date: 4 March 2006
  • Occupation: Sitting quietly in the corner
  • Location: fingers in ears singing lala
According to the post he flashed it with davinci. If you forum search there are lots of posts how to do it or you could send it back to sony for warrenty repair, details of how to do that are on the w880 forum
Posted: 20:04 13 Jul 08 #6

Im not trying to sound thick, but ive forum searched for a while, and been just looking through the k850i forum, and i really cant find any way to use Davinci, i think i have an idea on how to, but its still not too clear for me!

Can you point me in the direction of any of these posts? Im probably not looking hard enough! But hey, its hurting my head now!

 

Thanks in advanced!

Phreak

xx

Posted: 21:23 13 Jul 08 #7

Its no problem now! Got it working, it was TheBimbo1's phone, its all fixed now!

 

I used to Custom Blue Uk Firmware, works like a charm!

 

Thats me done a second one now, used excact same firmware, its perfect!

Posted: 12:11 14 Jul 08 #8
  • anitalg
  • 10490 Posts
  • anitalg
  • Join Date: 4 March 2006
  • Occupation: Sitting quietly in the corner
  • Location: fingers in ears singing lala
Um..glad you sorted it!
Posted: 07:59 05 Sep 08 #9
Yeah, they told me that the PCB keyboard needs replacing when this problem happens, so I had it done, AUD$125 later :(
Posted: 09:03 05 Sep 08 #10
  • hmd1987
  • 9 Posts
  • Join Date: 20 January 2007
ok i have searched on the forum but cant find a link to download this davinci software? anyone give me any info on it?
Posted: 09:11 05 Sep 08 #11
  • Yoni
  • 9208 Posts
  • Yoni
  • Join Date: 14 January 2004
  • Occupation: Tech, eXpansys Ltd
  • Location: Manchester UK

Sure, look here.

Yoni,
eXpansys Product Support,
Forum Search

Posted: 14:55 05 Sep 08 #12
  • hmd1987
  • 9 Posts
  • Join Date: 20 January 2007
never done this kind of thing before - what exactly do i need to download and run etc?
Posted: 16:47 05 Sep 08 #13
  • anitalg
  • 10490 Posts
  • anitalg
  • Join Date: 4 March 2006
  • Occupation: Sitting quietly in the corner
  • Location: fingers in ears singing lala

http://www.expansys.com/fs.aspx?argSearchCriteria=davinci+guide

 

there are a gazillion threads about davinci, have a look thru and you should find a guide

Posted: 03:32 24 Sep 08 #14
  • G_SAN
  • 1 Post
  • Join Date: 24 September 2008

 my k850i hang-up (freeze). waited for a while, nothing happens even i try pressing several keys. then i remove the battery and put it back again. i turned on my k850i but only the keypad keys light  n camera lights r on but no display on the screen - it freeze again (hang-up). so waited again for a couple of minutes, but nothing happens. i remove again the battery, put it back -> the same thing happens.... my k850i won't go back to normal...

any ideas about this problem...

Posted: 16:05 06 Oct 08 #15
  • Joshhwar
  • 1 Post
  • Join Date: 6 October 2008

I just paid the £8.14 for the software

I downloaded the client and everything

I went to download the "usb and phone drivers"

And i couldn't find the phone driver for this phone

Only the usb driver... so i dont think i know what i'm doing

Could someone please help??

I dont want to have wasted my money = /

Posted: 19:45 19 Oct 08 #16
  • Hi:)
  • 1 Post
  • Join Date: 19 October 2008

hey, im a complete noob at these things and my K850i wont turn on. well the lens does and so do the buttons. but i want to know where i can find a step by step tutorial on how to fix it... please if anyone knows i will be so gratefull!

 

thanks

 

 

Posted: 19:47 17 Jun 09 #17
  • ShoeQueen
  • 1 Post
  • Join Date: 17 June 2009
  • Location: Falkirk

Hey, I'm experiencing the same problem with my k850i, and I'm sorry to sound a bit dim but how do you flash the phone if it won't turn on?  I can connect it to my pc but it doesn't show up on my windows explorer.

 Thanks.

Posted: 19:39 06 Jul 09 #18
My K850 packed up today with the same problem.  I bought the credits from Da Vinci, but couldn't get very far as my laptop needed a "SEMCBOOT Download".  Now, I'm not the most techie of people and I couldn't figure out how to get it going again.  However, I then downloaded SEUS and this kickstarted the Da Vinci Service Client.  My phone appears to be fine now.  Thanks to all those who take the time to add to the forum.  You certainly saved me!
Posted: 13:25 07 Aug 09 #19
  • Kaicho
  • 2 Posts
  • Join Date: 7 August 2009

People, wait, wait, wait!!!!

I had exactly the same symptoms. The 'phone was unresponsive. When I finally got it to do something it vibrated briefly, all the key and camera lens lights lit and the phone was seemingly good for nothing. I was worried...

Go to update service at se.com. Below is the link for the UK:

http://www.sonyericsson.com/cws/support/softwaredownloads/detailed/updateservice/k850i?lc=en&cc=gb

Download and run the update service application and follow onscreen instructions. It took me 2 or 3 attempts after 'update' download for the 'update' to install correctly. Also, my battery was pretty much dead and I was not sure if it was still charging whilst 'unresponsive' so in addition to following the on-screen instructions I kept my 'phone charger connected whilst updating.

Now my 'phones working.

Posted: 13:32 07 Aug 09 #20
  • Kaicho
  • 2 Posts
  • Join Date: 7 August 2009

.... I forgot. It was thanks to this topic that I got thinking the Sony Ericsson updater might fix the problem (I'd forgotten about updating the firmware 12 months ago to fix a battery problem with the K850i!)

 So thank you all for reminding me!

Please suggest any improvements or report problems / abuse to moderator@expansys.com