Translate this page:

Welcome to our forums. Please sign-in or register

TomTom GO 4D00.001

Posted: 09:30 09 Sep 08 #1
  • Cliff7373
  • 1 Post
  • Join Date: 9 September 2008

My TomTom GO is an old one (model as above) and I want to update the maps which are out of date.

The update page does not recognize this model.

Is there a way of updating this model or do I have to start again with a new unit?

Thanks for your help

Cliff

Posted: 14:29 09 Sep 08 #2
  • Stowaway
  • 565 Posts
  • Stowaway
  • Join Date: 9 February 2008

Hi,

  By the' update page', do you mean the Tomtom 'Home' utility? If so ,which version of Home are you running? If it is 2.3 you may find that you need to roll back to 1.5 in order to update yourTomtom.

Please suggest any improvements or report problems / abuse to moderator@expansys.com