Translate this page:

Welcome to our forums. Please sign-in or register

K800i problem: phone has suddenly stopped working.

Posted: 21:53 18 Aug 06 #1
  • dafoz04
  • 16 Posts
  • dafoz04
  • Join Date: 18 August 2006
  • Occupation: student
  • Location: Brighton
Hi everyone,
i recently bought a K800i from 02 and its amazing, the picture quality is really good and basically its good. but i have been having some problems with it:

1. sometimes the screen turns white/blank and its turns off and then turns on itself.

2.just today someone called me , and i missed the call, i pressed back and instead it started to call the person after dialling it got stuck and didnt allow me to end the call unless the other person did.

3.then the same thing happened again, so i turned it off took the battery out and then put it in and turned it on. i left it on my table and came back to see that the screean went white/blank again.

4. so i turned it off and then tried to put it on again but it didnt. i have been trying to put it on but nothing happens, i even keep it on charge but still nothing. i am goin to ring SE up and find out but in the mean time could someone please tell me if this is a battery problem, or a malfunction.

thank you.
Posted: 22:05 18 Aug 06 #2
  • ParishYoung
  • 366 Posts
  • Join Date: 22 July 2006
  • Occupation: Orange Customer Services
Can you turn the phone on now??
There is a "software feature" where it needs to be left for a while before it can be powered on again.

I have had my phone crash once as well, did the whole White Screen thing and then tried to turn itself back on then died. left it a while and it came back on. (this was within a day of getting it SIM free so i paniced for a while there)

I'd monitor it for a while see if it contiues then if needed 'back to retailer'
Posted: 22:08 18 Aug 06 #3
  • dafoz04
  • 16 Posts
  • dafoz04
  • Join Date: 18 August 2006
  • Occupation: student
  • Location: Brighton
no i cant, its kinda wierd cause ive been lukin around and only 02 SE phones have this problem, which is confusing. hmmm yeah i dont no why have you returned yours to the retailer yet?

many thanks
Posted: 22:16 18 Aug 06 #4
  • ParishYoung
  • 366 Posts
  • Join Date: 22 July 2006
  • Occupation: Orange Customer Services
No it only did it after sending a large MP3 (8Mb) file to my bro.

It kinda took a big sigh of relief that it had finished and flopped down in a state of "rebooting-ness"

It's been fine since no problems at all - until tonight when my ba$tard network has died a horrible death. One of the main sites is down causing customers to get "No network coverage".

<--- As you can see here i'm on Orange
Posted: 22:23 18 Aug 06 #5
  • dafoz04
  • 16 Posts
  • dafoz04
  • Join Date: 18 August 2006
  • Occupation: student
  • Location: Brighton
oh ok, i just checked my phone but still nothing even if i try to turn it on and the surprising thing is ive only had it for 8 days lol! orange lol 02 is only gd at network otherwise they are crap. anyway thanks for your help in this matter

foz
Posted: 13:00 19 Aug 06 #6
  • benjy07
  • 127 Posts
  • benjy07
  • Join Date: 15 July 2006
  • Occupation: student
  • Location: UK
have you tried master reset? this may help as i think they may be a corrupted file on the phone... if this doesnt work then im afraid it looks like its heading back to the shop!
Posted: 13:48 19 Aug 06 #7
  • dafoz04
  • 16 Posts
  • dafoz04
  • Join Date: 18 August 2006
  • Occupation: student
  • Location: Brighton
no because the thing is i cant, it doenst turn on lol yeah rung em up today they sed dat dey will send me a new one all i gotta do is give da old one back. so basically swapping old to new :D thanks.
Posted: 16:15 21 Aug 06 #8
  • moby_buff
  • 62 Posts
  • moby_buff
  • Join Date: 8 January 2005
  • Occupation: Technical Support Advisor
  • Location: Manchester
Similar thing happened to me when i got a nokia 6280 from O2, had 3 replacements in a week, O2 stated that this would be due to them rushing the phones out before 'bugs' can be found, you may have got one of the first batches issued to O2.
Posted: 21:28 21 Aug 06 #9
It's not just 02. I've had this problem too and I'm on 3 network. It's only happened twice, but that's twice too many. First time was when the I plugged the charger in after my battery was flat. White screen came up. Second time it was just when I was messing around with it generally.
Posted: 23:29 21 Aug 06 #10
  • dafoz04
  • 16 Posts
  • dafoz04
  • Join Date: 18 August 2006
  • Occupation: student
  • Location: Brighton
hmmm yeah that sounds odd, and to the one above this post, u may be right about me getting it from the first batch, but they are sending a new one tomorrow so i guess it ok but im still gonna ask o2 about this. thanks for all your help everyone.

foz
Posted: 13:00 22 Aug 06 #11
  • moby_buff
  • 62 Posts
  • moby_buff
  • Join Date: 8 January 2005
  • Occupation: Technical Support Advisor
  • Location: Manchester
They can change it as many times as needed because you obviously have the 28 day return policy with faulty handsets. I know it happened to me on a nokia but its the same type of issue, the white screen of death - i had that issue as well on a SE w550i twice. Nothing has happened with my k800i yet (touch wood) but i didnt get it from o2, mine is locked to three so i hope this doesnt happen, its so annoying when it does!!
Posted: 16:09 22 Aug 06 #12
  • dafoz04
  • 16 Posts
  • dafoz04
  • Join Date: 18 August 2006
  • Occupation: student
  • Location: Brighton
yeah too true. it sucks when it happens but hey u still get it replaced lol yeah yours might not 'malfunction' like mine (still touch wood tho) lol very annoying indeed. thanks
foz
Posted: 18:57 23 Aug 06 #13
  • ParishYoung
  • 366 Posts
  • Join Date: 22 July 2006
  • Occupation: Orange Customer Services
I have been away for a few days and havie been taking a number of pictures with the new phone (i'll upload some in a bit). Also I have noticed the phone behaving in ways similar to the Nokia N series which I was really hoping wasn't going to happen.

The handset has got stuck when sending or receiving messages and moving round the menu.

Here's what i did to fix it.

1) Disable 3G immediately
2) Move all files (where possible) to the memory card
3) Delete ALL unwanted message - Inbox & Sent

All seems fine now. See if this helps.
Posted: 21:37 23 Aug 06 #14
  • dafoz04
  • 16 Posts
  • dafoz04
  • Join Date: 18 August 2006
  • Occupation: student
  • Location: Brighton
yeah it dus go wierd, thanks for the info, u see i cant really turn my phone on lol so i cant even do that BUT i got a new one comin tomoz, so if dat happens ill be sure 2 do dat, all i need is a memory card.... lol thanks for your help.
foz
Posted: 23:52 23 Aug 06 #15
  • ParishYoung
  • 366 Posts
  • Join Date: 22 July 2006
  • Occupation: Orange Customer Services
Well you're already on the right wesbite for memory cards chief.
Posted: 13:30 22 Dec 06 #16
  • performingarts
  • 2 Posts
  • Join Date: 22 December 2006
  • Occupation: student
hey

i bought a k800i last week, and just an hour ago it, totally died on me, it wont turn on, put a different sim, still wont and charging it doesnt help either,

which sounds alot like your problem!!!

so what did u do, did u ring the shop??
cheers
Posted: 12:39 14 Jan 07 #17
  • juleswendy
  • 1 Post
  • Join Date: 14 January 2007
  • Occupation: activities coordinator
I too have had dire proiblems with my k800i from 02 it freezes it white screens wont voice dial loses applications that I downloaded at cost.when I put my soft ware on it crashed my pc and caused probs to my hard drive I had to get someone in to reinstall windows.Then the other day it died completely.I took it back to 02 shop who said your just outside 28 days period by 4 days..So it will have to go for repair.I wasnt happy argued for ages getting no where about cost to me broken computer lost work etc on computer photos etc time with out pc there negative attitude when I first complained about this.ie throw disc in bin and down load from sony when you get pc fixed.I spoke to custumer services who said its at shops discresion after 28 days,shop said it was up to 02 so basically playing piggy in middle with me.Im just off to write letters of complaint to sony and o2.
Posted: 07:56 17 Jan 07 #18
  • madhavs
  • 1 Post
  • Join Date: 17 January 2007
I''ve had a similar experience... I got a SE K800i from Singapore and have been using it in Bangalore India for about 3 weeks now. Had no problem so far, but today I was at work and had just left the phone on my desk for about an hour (was not doing anything on the phone) and when I picked it up the screen was all messed there were horizontal likes and fuzzy stuff all over. So I switched it off n on.. still no use the same fuzzy stuff came back. I''m not sure what went wrong... any suggestions? Can''t make or receive calls and I really need my phone to be working!!!
Thanks in advance!
Posted: 22:01 16 Feb 07 #19
  • dafoz04
  • 16 Posts
  • dafoz04
  • Join Date: 18 August 2006
  • Occupation: student
  • Location: Brighton
Hey guys, guess what... my second K800i just crashed again grrr... its showing one red flash, then six constant ones by the infra-red port. It is still in warranty so will be getting a new one, but i think i might change my phone, sony ericsson has some k800i issues that they really need to sort out. I hope the rest of you with the same problem have had your phones replaced/repaired.

-foz''-
Posted: 23:56 17 Feb 07 #20
  • selene
  • 7043 Posts
  • selene
  • Join Date: 26 April 2004
  • Occupation: Yons is my Master. I have been chosen. :-D
Sorry to hear that. Hope you have better luck with whatever phone you get next :-)

Selene
Please suggest any improvements or report problems / abuse to moderator@expansys.com